Connectivity Issues
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 08, 2017 - 15:17 GMT
Investigating
We are investigating reduced or slower connectivity for some customers with the DeskPRO platform.
Posted over 2 years ago. Mar 08, 2017 - 15:03 GMT