Connectivity Issues
Incident Report for Deskpro
Resolved
This issue has now been resolved. We will update with further information post a root-cause analysis.
Posted over 1 year ago. Apr 24, 2018 - 15:21 BST
Investigating
We are investigating connectivity issues affecting some customers.
Posted over 1 year ago. Apr 24, 2018 - 15:12 BST