Investigating Connectivity Issues
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 26, 2019 - 00:38 BST
Investigating
We are investigating connectivity issues affecting some customers.
Posted about 2 months ago. Jun 25, 2019 - 23:48 BST