Connection Issues
Incident Report for Deskpro
Resolved
The datacenter impacted has restored connectivity and services have all resumed. We are investigating the route cause.
Posted 6 months ago. Feb 21, 2019 - 17:16 GMT
Investigating
We are investigating connection issues on the platform.
Posted 6 months ago. Feb 21, 2019 - 17:11 GMT