Connection Issues
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 29, 2019 - 11:29 BST
Monitoring
The service is restored and we continue to monitor.
Posted about 2 months ago. Jun 28, 2019 - 18:29 BST
Investigating
We are currently investigating connectivity issues affecting some customers.
Posted about 2 months ago. Jun 28, 2019 - 18:04 BST