Connection Issues
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted 4 months ago. May 03, 2019 - 15:03 BST
Update
We are continuing to investigate this issue.
Posted 4 months ago. May 03, 2019 - 15:03 BST
Investigating
We are currently investigating slow speed or failed connections affecting some customers.
Posted 4 months ago. May 03, 2019 - 14:50 BST