Connectivity Issues
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 17, 2019 - 10:29 BST
Investigating
We are currently investigating connectivity issues
Posted 2 months ago. Jun 17, 2019 - 10:23 BST