Connectivity Issues
Incident Report for Deskpro
Resolved
This issue has been resolved.
Posted 9 months ago. Nov 26, 2018 - 12:50 GMT
Investigating
We are investigating connectivity issues affecting some customers.
Posted 9 months ago. Nov 26, 2018 - 12:46 GMT