Connectivity Issues
Incident Report for Deskpro
Resolved
An internal networking issue affected some customers for approximately 4 minutes. This issue has now been resolved.
Posted 12 days ago. Aug 09, 2019 - 14:51 BST
Investigating
We are currently investigating connectivity issues affecting some customers.
Posted 12 days ago. Aug 09, 2019 - 14:47 BST