Network Issues
Incident Report for Deskpro
Resolved
Our engineers have resolved the issue and all sites have returned to normal. Our apologies for this interruption.
Posted over 2 years ago. Feb 20, 2017 - 14:41 GMT
Investigating
We are investigating network issues affecting some customers.
Posted over 2 years ago. Feb 20, 2017 - 14:35 GMT