Connectivity Issues
Incident Report for Deskpro
Resolved
This issue is now resolved.
Posted almost 3 years ago. Nov 05, 2016 - 12:16 GMT
Investigating
We are investigating connectivity issues affecting some DeskPRO Cloud customers.
Posted almost 3 years ago. Nov 05, 2016 - 11:09 GMT