Connectivity Issues
Incident Report for Deskpro
Resolved
This incident has been resolved.
Posted almost 3 years ago. Aug 28, 2016 - 13:29 BST
Investigating
We are investigating connectivity issues affecting some DeskPRO Cloud customers.
Posted almost 3 years ago. Aug 28, 2016 - 13:23 BST